Introduction

This resource is one result of the training courses on Bash scripting for audiovisual archivists Reto Kromer is giving since 2017.

 

This resource covers mainly GNU Bash version 4.4 (released on 2016–09–15), but we strongly recommend to use the current version 5.0 (released on 2019–01–07). However, many parts applies also to GNU Bash 3.2 (released on 2006–10–11) which, sadly, is still installed by Apple with today’s macOS. Note that we didn’t check any compatibility with versions older than 2.04 (released on 2000–03–21).


2020–07–16